香港挂牌全篇最完整篇+香港挂牌彩图2020,香港挂牌 香港挂牌全篇最完整篇+香港挂牌彩图2020,香港挂牌

通达信自动划线指标及选股警告公式

自动划线公式

HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);

QY:=BACKSET(AA,HIGHN+1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);

DRAWICON(CC,H*1.02,2);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DINGBU1:=REF(DINGBU,DDD+1);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD+1);

GDCS2:=CONST(DINGBUTS1);

DINGBU2:=REF(DINGBU1,DDD+1);

MM:=IF(CURRBARSCOUNT>GDCS2,0,1);

高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;

相对高点:DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;

AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);

QY1:=BACKSET(AA1,LOWN+1);

CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);

DRAWICON(CC1,L*0.98,1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

YDB:=IF(DD1,REF(L,DD1),L);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

ZDB:=REF(YDB,DD1+1);

DDTS2:=REF(DDTS1,DD1+1);

DDCS2:=CONST(DDTS2);

低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK2;

ZGSTAR:=(高点压力+低点支撑)/2;

ZGEND:=CONST((高点压力+低点支撑)/2);

STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);

中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK2;

DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;

DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;

自动划线预警选股

HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);

QY:=BACKSET(AA,HIGHN+1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DINGBU1:=REF(DINGBU,DDD+1);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD+1);

GDCS2:=CONST(DINGBUTS1);

DINGBU2:=REF(DINGBU1,DDD+1);

MM:=IF(CURRBARSCOUNT>GDCS2,0,1);

高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;

压力线选股:CROSS(C,高点压力)>0.5;

免责声明:本文仅代表文章作者的个人观点,与本站无关。其原创性、真实性以及文中陈述文字和内容未经本站证实,对本文以及其中全部或者部分内容文字的真实性、完整性和原创性本站不作任何保证或承诺,请读者仅作参考,并自行核实相关内容。

/style/images/nopic.gif
我要收藏
赞一个
踩一下
分享到

分享
评论
首页
分享到:QQ空间新浪微博腾讯微博人人网微信